Intrepid Ibex: Ubuntu 8.10

/!\ Avant d’upgrader votre distribution vers la 8.10

1. mieux vaut lire « un peu » la documentation :)
2. est ce que vous êtes certain de vouloir le faire?

En tout cas, je vous conseille fortement de ne pas changer de version d’Ubuntu. Et pour ceux qui ont envie juste d’essayer une version d’Ubuntu, et qui n’ont jamais essayé de le faire dans leurs vies, je vous propose de tester la version 8.04 qui est une version très stable.

Ceci dit, je vous remets ici le lien pour la documentation: http://doc.ubuntu-fr.org/migration_hardy_intrepid

Je me suis apperçu que j’avais pas le paquet ubuntu-desktop, et donc je me suis précipité pour l’installer. Une fois ceci fait, vous pouvez écrire dans une console pour lancer l’upgrade:
gksu ‘update-manager -c’

Si comme moi, vous ne voyez pas une upgrade de votre système, il faut aller dans le logiciel « Sources de logiciel », puis dans l’onglet « Mise à jour » il faut choisir « Mise à niveau de la version: Versions normales »


Puis en lançant la même commande de mise-à-jour vous devriez avoir maintenant la dernière version disponible:


Et zou .. j’y vais pour l’upgrade


Mouais … après celà, je suis bien passé à la version 8.10, par contre je n’ai plus d’interface graphique. Je me suis dit heureusement que j’avais une copie de mon xorg.conf, que j’ai remis à la place du nouveau, mais toujours rien. J’ai toujours pas de mode graphique :(

Puis après, pourquoi ne pas essayer de lancer Ubuntu en mode « recovery » et voir ce que çà donne. Ben, pour çà il fallait choisir d’abord l’option « Xfix », puis de démarrer en mode normal. Génial !! Çà y est, j’ai mon interface graphique. Mais malheureusement, en rebootant, toujours le même problème: pas d’interface graphique.

La solution est donc de réinstaller ma carte graphique, et tout ce qu’il faut pour pour.

1- j’ai supprimé le paquet fglrx:

sudo apt-get remove fglrx*

2- puis une petite mise à jour

sudo apt-get update

3- je me suis lancé à suivre la procédure comme ici http://wiki.cchtml.com/index.php/Ubuntu … tion_Guide sans oublier de faire une copie de mon xorg.conf avant de lancer les commandes suivantes:

$ sudo apt-get update
$ sudo apt-get install linux-restricted-modules-generic restricted-manager
$ sudo apt-get install xorg-driver-fglrx
$ sudo depmod -a

Après celà, j’ai vérifier mon fichier xorg.conf si j’ai bien quelque chose comme ca:

Section « Device »
[…]
Driver « fglrx »
Option « VideoOverlay » « on »
Option « OpenGLOverlay » « off »
[…]
EndSection

Puis j’ai comparé mon ancien xorg.conf avec le nouveau, et rajouter dans le nouveau ce qui manque :)
Et voilà, les nouveaux pilotes de ma carte graphique ont été installé en même temps.

Sources:
migration de la version 8.04 vers la 8.10 (fr)
guide d’installation d’Ubuntu Intrepid
drivers pour les cartes ATI

Publicités

IRC et pidgin

Pour ceux qui veulent utiliser pidgin pour se connecter à IRC, ce n’est pas bien difficile.

Dans un premier temps, il faut aller dans Comptes/Gérer les comptes/Ajouter, puis vous devriez avoir cette fenêtre qui s’affiche:


Dans cette fenêtre, il suffit juste de rajouter le nom d’utilisateur, puis de garder le server qui est déjà proposé. Ensuite, il faut cliquer sur « Avancé » pour rajouter votre nom réel si vous le souhaitez.

Et enfin, si tout se passe bien, vous devriez avoir une nouvelle fenêtre qui s’ouvre, dans lequel il faut rentrer le nom du canal où vous souhaitez rentrer en écrivant /join #nom_du_canal dans la zone d’écriture.


Et voilà, vous êtes connecté à IRC sous pidgin.

Sources:
explication en anglais
commandes IRC de base et avancées
support pour Ubuntu sur IRC

Mise-à-jour vers Pidgin 2.5.2 non automatisée?


Mise-à-jour de pidgin 2.5.2 à partir de la version 2.5.0 : un vrai parcours du combattant :)

Il faut tout d’abord télécharger l’archive à partir du site officiel de pidgin.

http://www.pidgin.im/

Après décompression du fichier, et lorsque je lance dans une console:

./configure

Voici mon message d’erreur:

GtkSpell development headers not found

Pour résoudre ce problème, il faut aller dans Synaptic, et installer le paquet glibgtkspell-dev
Quand c’est fait, j’ai relancé un ./configure , et encore une fois, j’ai plus ou moins le même soucis que précédement:

Use --disable-gstreamer if you do not need GStreamer (sound) support pidgin

Et la, je me suis dit que ce ne serait peut-être pas le dernier soucis que je vais avoir,et donc j’ai du aller visiter le site officiel de pidgin pour voir les solutions qu’ils proposent, entre autre celle ci pour installer toutes les dépendances automatiquement:

sudo apt-get build-dep pidgin

Mais bon, il ne faut pas croire que tout est rose :) … un nouveau message d’erreur:

E: Vous devez insérer quelques adresses « sources » dans votre sources.list

Et oui, tout est dit, donc il faut ajouter les 2 lignes suivantes dans votre source.list (que vous pouvez récupérer sur: https://launchpad.net/~pidgin-developers/+archive)

deb http://ppa.launchpad.net/pidgin-developers/ubuntu hardy main
deb-src http://ppa.launchpad.net/pidgin-developers/ubuntu hardy main

Après cela, j’ai espéré que cette fois ci je ne vais plus avoir de problème en relançant ma recherche de dépendance:

sudo apt-get build-dep pidgin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les NOUVEAUX paquets suivants seront installés :
check doxygen libcamel1.2-dev libdb-dev libdb4.6-dev libebook1.2-dev
libedata-book1.2-dev libedataserver1.2-dev libgadu-dev libgstreamer0.10-dev
liblaunchpad-integration-dev libltdl3-dev libmeanwhile-dev libncursesw5-dev
libnm-util-dev libnspr4-dev libnss3-dev libperl-dev libsasl2-dev
libsilc-1.1-2-dev libsqlite3-dev libxt-dev libzephyr-dev network-manager-dev
tcl8.4-dev tk8.4 tk8.4-dev
0 mis à jour, 27 nouvellement installés, 0 à enlever et 3 non mis à jour.
Il est nécessaire de prendre 11,3Mo dans les archives.
Après cette opération, 65,9Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? O

J’ai ensuite l’icône de mise à jour, est-ce enfin une bonne nouvelle?!

Malheureusement, cette MAJ est juste pour le passage de la version 2.5.0 vers la 2.5.1

Et donc, je retente un ./configure puisque j’ai téléchargé la version 2.5.2

Pidgin will be installed in /usr/local/bin.
Warning: You have an old copy of Pidgin at /usr/bin/pidgin.

configure complete, now type 'make'

$make

Le fait de lancer un ‘make’ dure un petit moment, avec tout plein de texte incompréhensible pour le commun des mortels :) … et donc il faut savoir patienter. Puis tout à l’air bon, je tente la dernière manipulation:

sudo make install

Ouf, j’y suis arrivé finalement. Bon courage à ceux qui veulent tenter aussi de leur côté.

Sources:
site officiel de pidgin
l’archive pour la version 2.5.2
la source.lst pour pidgin

Fanorona: un jeux de société malgache

Celà fait un petit moment que je cherchais un jeux de fanorona pour mon pc, et qui marche sur Ubuntu bien sur ;)

Je ne vais pas vous faire un commentaire sur comment on y joue, et quel sont les règles, vu qu’à la base ce blog me sert juste de mémento personnel. Je vous renvoie donc aux différents liens cités en bas de page pour plus d’information sur ce jeux de société malgache.

Pour l’installation, il faut installer les paquets suivants:

sudo apt-get install python python-numeric python-pygame

Puis ensuite, il faut rajouter à votre fichier /etc/apt/sources.list la ligne suivante:

deb http://randrianiriana.org/debian/ ./

Et enfin, pour l’installation du jeux, après une mise-à-jour de votre système avec apt-get update:

sudo apt-get install fanorona

Le jeux, vous pouvez le retrouver dans le menu « Applications/Jeux/Fanorona ». Bon jeux à tous et à toutes bien sur.


En ce qui concerne les informations sur comment utiliser le programme, je vous conseille de lire la documentation à cet URL: http://home.gna.org/fanorona/screenshots.html

Sources et liens utiles:
– Merci à Thierry Randrianiriana de nous avoir dévellopé ce programme
Histoire du fanorona
Règles du jeux

Installation de GIMP 2.6 sur Hardy

Pour ceux qui tentent de faire une mise-à-jour de leur logiciel GIMP, à partir de « apt-get update » çà ne marche pas si vous êtes sous hardy.

Il faut tout d’abord se rendre sur le site http://www.getdeb.net/release/3233, puis si vous faîtes le malin comme moi, en essayant de cliquer directement sur « Download: gimp (4.2 MB) » vous allez recevoir comme message qu’il faut dans un premier temps désinstaller l’ancienne version de gimp en tapant la commande « apt-get install -f ». C’est ce qu’on va faire dans une console justement:

malagasy@malagasy-laptop:~$ sudo apt-get install -f

Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Correction des dépendances… Fait

Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
libxml-libxml-common-perl libxml-namespacesupport-perl python2.4-minimal
python2.4 libxml-libxml-perl libxml-sax-perl libpt-1.10.10-plugins-v4l
Veuillez utiliser « apt-get autoremove » pour les supprimer.

Les paquets suivants seront ENLEVÉS :
gimp
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 10,9Mo d’espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? O
(Lecture de la base de données… 244914 fichiers et répertoires déjà installés.)
Suppression de gimp …
localepurge: Disk space freed in /usr/share/locale: 22556K

Puis comme c’est marqué qu’il y a des paquets qui ne sont plus nécessaire, je les ai donc supprimés tout bonnement.

malagasy@malagasy-laptop:~$ sudo apt-get autoremove

Puis maintenant, on peut installer les paquets mais dans l’ordre suivant pour éviter le message de problème de dépendance:

gimp-data, libbabl-0.0-, libgegl-0.0-0, gimp, libgimp2.0, gimp-python, gimp-libcurl, gimp-gnomevfs

Et voilà vous avez la version 2.6 sur votre PC

Mignonnes les vaches de l’Aveyron?! ;)

Sources:
http://www.getdeb.net/release/3233
http://www.gimp.org/

J’en profite de cette page pour rajouter d’autres liens intéressants et qui peuvent être utiles:

http://www.liberkey.com/tous-les-logiciels.html
http://tuto-gimp.com/