Cisco: NAT – OSPF – FR – ACL

Fichier a telecharger: nat_clean.pkt

Logiciel: packet tracer

DLCI:

102 201 = R1 vers R2 // 80.0.0.0/30
103 301 = R1 vers R3 // 80.0.0.4/30
203 302 = R2 vers R3 // 80.0.0.8/30

– Configurer Frame Relay
– Mettre en place OSPF+MD5

– Mettre en place du PAT pour les hotes du subnet
192.168.1.0/24

– Mettre en place du NAT Static pour les hotes du subnet
192.168.2.0/25 avec les IP suivantes:
82.0.0.1 pour 192.168.2.1
82.0.0.2 pour 192.168.2.2

– Mettre en place du NAT Dynamic pour les hotes du subnet
192.168.3.0/2- avec le pool suivant:
83.0.0.10 à 83.0.0.20/27

– Mettre en place des ACL pour authoriser l’acces uniquement
en HTTP sur le serveur

****************************************************

Correction

****************************************************

Configuration des interfaces LAN & DHCP pour chaque LAN:
======================================
R1
 » » » » »’
Router(config)#hostname Router1
Router1(config)#no ip domain-lookup
    (config)#line console 0
    (config-line)#logging synchronous

Router1(config)#int f0/0
    (config-if)#description vers Switch0
    (config-if)#ip address 192.168.1.254 255.255.255.0
    (config-if)#no shutdown

Router1(config)#ip dhcp pool LAN1
    (dhcp-config)#network 192.168.1.0 255.255.255.0
    (dhcp-config)#default-router 192.168.1.254
    (dhcp-config)#dns-server 8.8.8.8

R2
 » » » » »’
Router(config)#hostname Router2
Router2config)#no ip domain-lookup
    (config)#line console 0
    (config-line)#logging synchronous

Router2(config)#int f0/0
    (config-if)#description vers Switch2
    (config-if)#ip address 192.168.2.126 255.255.255.128
    (config-if)#no shutdown

Router2(config)#ip dhcp pool LAN2
    (dhcp-config)#network 192.168.2.0 255.255.255.128
    (dhcp-config)#default-router 192.168.2.126
    (dhcp-config)#dns-server 8.8.8.8

Router2(config)#ip dhcp excluded-address 192.168.2.100 ##pour le serveur, mieux vaut prendre une adresse statique
Router2#ping 192.168.2.1 ##l’adresse du serveur

R3
 » » » » »’
Router(config)#hostname Router3
Router3(config)#no ip domain-lookup
    (config)#line console 0
    (config-line)#logging synchronous

Router3(config)#int f0/0
    (config-if)#description vers Switch1
    (config-if)#ip address 192.168.3.62 255.255.255.192
    (config-if)#no shutdown

Router3(config)#ip dhcp pool LAN3
    (dhcp-config)#network 192.168.3.0 255.255.255.192
    (dhcp-config)#default-router 192.168.3.62
    (dhcp-config)#dns-server 8.8.8.8

Configuration de Frame-Relay
========================================
On va mettre en place un PVC pour chaque destination, afin de faire du point-to-point plutot que du multipoint qui poserait probleme pour nos MAJ de routage. Ainsi on pourra obtenir un PVC pour chaque subnet.

/!\ Pas d’adresse IP sur l’interface physique.

Pour s’y retrouver facilement on utilisera un DLCI pour chaque sub-interface.

R1
 » » » » »’
Router1(config)# int s0/1/0
    (config-if)#encapsulation frame-relay   #Cisco par defaut
    (config-if)# no shutdown

Router1(config)#int s0/1/0.102 point-to-point
    (config-subif)#ip address 80.0.0.1 255.255.255.252
    (config-subif)#frame-relay interface-dlci 102
    (config-subif)#bandwidth 128

Router1(config)#int s0/1/0.103 point-to-point
    (config-subif)#ip address 80.0.0.6 255.255.255.252
    (config-subif)#frame-relay interface-dlci 103
    (config-subif)#bandwidth 128

R2
 » » » » »’
Router2(config)#int s0/1/0
    (config-if)#encapsulation frame-relay
    (config-if)#no shutdown

Router2    (config)#int s0/1/0.201 point-to-point
    (config-subif)#frame-relay interface-dlci 201
    (config-subif)#ip address 80.0.0.2 255.255.255.252
    (config-subif)#bandwidth 128

Router2(config)#int s0/1/0.203 point-to-point
    (config-subif)#frame-relay interface-dlci 203
    (config-subif)#ip address 80.0.0.9 255.255.255.252
    (config-subif)#bandwidth 128

R3
 » » » » »’
Router3(config)#int s0/1/0
    (config-if)#encapsulation frame-relay
    (config-if)#no shutdown 

Router3(config)#int s0/1/0.301 point-to-point
    (config-subif)#frame-relay interface-dlci 301
    (config-subif)#ip address 80.0.0.5 255.255.255.252
    (config-subif)#bandwidth 128

Router3(config)#int s0/1/0.302 point-to-point
    (config-subif)#frame-relay interface-dlci 302
    (config-subif)#ip address 80.0.0.10 255.255.255.252
    (config-subif)#bandwidth 128

Remarque:
Router3(config-if)#int s0/1/0.301
%Cannot create sub-interface
Router3(config)#int s0/1/0.301 point-to-point

%LINK-5-CHANGED: Interface Serial0/1/0.301, changed state to up
Router3(config-subif)#

======================================================================
Frame-Relay Troubleshooting
======================================================================
Router1#ping 80.0.0.2
  Type escape sequence to abort.
  Sending 5, 100-byte ICMP Echos to 80.0.0.2, timeout is 2 seconds:
  …..
  Success rate is 0 percent (0/5)
Router1#ping 80.0.0.1
  Type escape sequence to abort.
  Sending 5, 100-byte ICMP Echos to 80.0.0.1, timeout is 2 seconds:
  …..
  Success rate is 0 percent (0/5)

Router1#show ip int s0/1/0.102
Serial0/1/0.102 is up, line protocol is down (disabled)
  Internet address is 80.0.0.1/30
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500
  !—-message tronque—!

Router1#show int s0/1/0
Serial0/1/0 is up, line protocol is down (disabled)
  Hardware is HD64570
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation Frame Relay, loopback not set, keepalive set (10 sec)
  LMI enq sent  81, LMI stat recvd 81, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
  !—-message tronque—!
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Router#show run
  !—-message tronque—!
interface Serial0/1/0
 no ip address
 encapsulation frame-relay ietf
 frame-relay lmi-type ansi
!
interface Serial0/1/0.102 point-to-point
 bandwidth 128
 ip address 80.0.0.1 255.255.255.252
 frame-relay interface-dlci 102
  !—-message tronque—!

Router1#show frame-relay lmi
LMI Statistics for interface Serial0/1/0 (Frame Relay DTE) LMI TYPE = ANSI
 Invalid Unnumbered info 0      Invalid Prot Disc 0
 Invalid dummy Call Ref 0       Invalid Msg Type 0
 Invalid Status Message 0       Invalid Lock Shift 0
 Invalid Information ID 0       Invalid Report IE Len 0
 Invalid Report Request 0       Invalid Keep IE Len 0
 Num Status Enq. Sent 51        Num Status msgs Rcvd 50
 Num Update Status Rcvd 0       Num Status Timeouts 16

LMI Statistics for interface Serial0/1/0.102 (Frame Relay DTE) LMI TYPE = ANSI
 Invalid Unnumbered info 0      Invalid Prot Disc 0
 Invalid dummy Call Ref 0       Invalid Msg Type 0
 Invalid Status Message 0       Invalid Lock Shift 0
 Invalid Information ID 0       Invalid Report IE Len 0
 Invalid Report Request 0       Invalid Keep IE Len 0
 Num Status Enq. Sent 0         Num Status msgs Rcvd 0
 Num Update Status Rcvd 0       Num Status Timeouts 16

Il semble bien qu’il y a echange de LMI et qu’on n’a pas de probleme de configuration. Du cote du provider, apres avoir verifie le type de LMI, il apparait que c’est de type Cisco, d’ou le message « line protocol is down » sur nos interfaces vu qu’on utilise deux protocols differents.

======================================================================

Verification
« « « « « « « « « `
Router3#show frame-relay pvc

PVC Statistics for interface Serial0/1/0 (Frame Relay DTE)
DLCI = 301, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0.301

input pkts 14055       output pkts 32795        in bytes 1096228
out bytes 6216155      dropped pkts 0           in FECN pkts 0
in BECN pkts 0         out FECN pkts 0          out BECN pkts 0
in DE pkts 0           out DE pkts 0
out bcast pkts 32795   out bcast bytes 6216155

DLCI = 302, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1/0.302

input pkts 14055       output pkts 32795        in bytes 1096228
out bytes 6216155      dropped pkts 0           in FECN pkts 0
in BECN pkts 0         out FECN pkts 0          out BECN pkts 0
in DE pkts 0           out DE pkts 0
out bcast pkts 32795   out bcast bytes 6216155



Configuration de OSPF + MD5
===============================

R1
« « « « « 
Router1(config)#router ospf 1
    (config-router)#network 192.168.1.0 0.0.0.255 area 0
    (config-router)#network 80.0.0.0 0.0.0.3 area 0
    (config-router)#network 80.0.0.4 0.0.0.3 area 0
    (config-router)#passive-int f0/0

R2
« « « « « `
Router2(config)#router ospf 2
    (config-router)#network 192.168.2.0 0.0.0.127 area 0
    (config-router)#network 80.0.0.0 0.0.0.3 area 0
    (config-router)#network 80.0.0.8 0.0.0.3 area 0
    (config-router)#passive-int f0/0

R3
« « « « « « `
Router3(config)#router ospf 3
    (config-router)#network 192.168.3.0 0.0.0.63 area 0
    (config-router)#network 80.0.0.4 0.0.0.3 area 0
    (config-router)#network 80.0.0.8 0.0.0.3 area 0
    (config-router)#passive-interface f0/0

======================================================================
OSPF Troubleshooting
======================================================================
Router1#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.2.126     0   FULL/  –        00:00:36    80.0.0.2        Serial0/1/0.102
192.168.3.62      0   FULL/  –        00:00:31    80.0.0.5        Serial0/1/0.103

Router2#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.254     0   FULL/  –        00:00:32    80.0.0.1        Serial0/1/0.201

Router3#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.254     0   FULL/  –        00:00:32    80.0.0.6        Serial0/1/0.301

Router3#show ip int s0/1/0.302
Serial0/1/0.302 is up, line protocol is up (connected)
  Internet address is 80.0.0.10/30
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500

Router2#show ip int s0/1/0.203
Serial0/1/0.203 is up, line protocol is up (connected)
  Internet protocol processing disabled

Router2#show running-config
  !—-message tronque—!
interface Serial0/1/0.203 point-to-point
 bandwidth 128
 no ip address
 frame-relay interface-dlci 203
  !—-message tronque—!

Le probleme est resolu en appliquant une adresse ip sur l’interface s0/1/0.203 de R2.

Router2(config-subif)#ip address 80.0.0.9 255.255.255.0
% 80.0.0.0 overlaps with Serial0/1/0.201
Router2(config-subif)#ip address 80.0.0.9 255.255.255.252
Router2(config-subif)#
11:23:21: %OSPF-5-ADJCHG: Process 2, Nbr 192.168.3.62 on Serial0/1/0.203 from LOADING to FULL, Loading Done

Router2#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
       i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
       * – candidate default, U – per-user static route, o – ODR
       P – periodic downloaded static route

Gateway of last resort is not set

     80.0.0.0/30 is subnetted, 3 subnets
C       80.0.0.0 is directly connected, Serial0/1/0.201
O       80.0.0.4 [110/1562] via 80.0.0.1, 00:02:32, Serial0/1/0.201
                 [110/1562] via 80.0.0.10, 00:02:32, Serial0/1/0.203
C       80.0.0.8 is directly connected, Serial0/1/0.203
O    192.168.1.0/24 [110/782] via 80.0.0.1, 00:20:51, Serial0/1/0.201
     192.168.2.0/25 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, FastEthernet0/0
     192.168.3.0/26 is subnetted, 1 subnets
O       192.168.3.0 [110/782] via 80.0.0.10, 00:02:32, Serial0/1/0.203

======================================================================

Auth MD5 + modification des hello-intervalles
 » » » » » » » » » » » » » » » »’
RAPPEL: OSPF demande a ce que les routeurs aient le meme hello et dead interval pour mettre en place une relation de voisinage.

R1
« « « « 
Router1(config)#int s0/1/0.102
    (config-subif)#ip ospf hello-int 2
    (config-subif)#ip ospf dead-int 6
    (config-subif)#int s0/1/0.103
    (config-subif)#ip ospf hello-int 2
    (config-subif)#ip ospf dead-int 6

R2
« « « « 
Router2(config)#int s0/1/0.201
    (config-subif)#ip ospf hello-int 2
    (config-subif)#ip ospf dead-int 6
    (config-subif)#int s0/1/0.203
    (config-subif)#ip ospf hello-int 2
    (config-subif)#ip ospf dead-int 6

R3
« « « « 
Router3(config)#int s0/1/0.301
    (config-subif)#ip ospf hello-int 2
    (config-subif)#ip ospf dead-int 6
    (config-subif)#int s0/1/0.302
    (config-subif)#ip ospf hello-int 2
    (config-subif)#ip ospf dead-int 6

Verification
« « « « « « « « « `
Router# show ip ospf neighbor

Mise-en-place de l’auth
« « « « « « « « « « « « « 

Router1(config-subif)#int s0/1/0.102
    (config-subif)#ip ospf authentication message-digest
    (config-subif)#ip ospf message-digest-key 1 md5 egilia

Router1(config-subif)#int s0/1/0.103
    (config-subif)#ip ospf authentication message-digest
    (config-subif)#ip ospf message-digest-key 10 md5 learning


Router2(config-subif)#int s0/1/0.201
    (config-subif)#ip ospf authentication message-digest
    (config-subif)#ip ospf message-digest-key 1 md5 egilia

Router2(config-subif)#int s0/1/0.203
    (config-subif)#ip ospf authentication message-digest
    (config-subif)#ip ospf message-digest-key 2 md5 openforma


Router1(config-subif)#int s0/1/0.301
    (config-subif)#ip ospf authentication message-digest
    (config-subif)#ip ospf message-digest-key 10 md5 learning

Router1(config-subif)#int s0/1/0.302
    (config-subif)#ip ospf authentication message-digest
    (config-subif)#ip ospf message-digest-key 2 md5 openforma

Verification
« « « « « « « « « `
Router# show ip ospf neighbor

Configuration du PAT
================================
1. Definir les interfaces inside/outside
2.creer l’ACL qui va permettre de definir les interfaces a translater
3. creer la regle PAT

/!\ ne pouvant avoir deux regles PAT utilisant la meme ACL, on va creer PAT_2 pour lier a la sub-interface qui va vers R2 et PAT_3 pour celle vers R3

Router1(config)#int f0/0
    (config-if)#ip nat inside
Router1(config-if)#int s0/1/0.102
    (config-subif)#ip nat outside
Router1(config-subif)#int s0/1/0.103
    (config-subif)#ip nat outside

Router1(config)#ip access-list standard PAT_2
    (config-std-nacl)#permit 192.168.1.0 0.0.0.255
Router1(config)#ip access-list standard PAT_3
    (config-std-nacl)#permit 192.168.1.0 0.0.0.255

Router1(config)#ip nat inside source list PAT_2 int s0/1/0.102 overload
    (config)#ip nat inside source list PAT_3 int s0/1/0.103 overload

Remarque: nos host peuvent ainsi aller sur le reseau WAN, et de plus ils sont inconnus par les hotes externes qui ne connaissent que l’IP publique utilisee
par nos hotes pas pas les IP privees, ce qui va ameliorer la securite.

Verification
« « « « « « « « 
1. show running-config
2. show ip nat translation
3. show ip nat statistics

PC0>ping 192.168.2.100

Router1#show ip nat translations
Pro  Inside global     Inside local       Outside local      Outside global
icmp 80.0.0.1:11       192.168.1.2:11     192.168.2.100:11   192.168.2.100:11

Router1#show ip nat statistics
Total translations: 1 (0 static, 1 dynamic, 1 extended)
Outside Interfaces: Serial0/1/0.102 , Serial0/1/0.103
Inside Interfaces: FastEthernet0/0
Hits: 8  Misses: 21
Expired translations: 10
Dynamic mappings:

Misses: 21, indique que 21 paquets n’etaient pas dans la table de translation NAT, ce qui en resulte que le routeur va les ajouter dans sa table.

Nombres de Misses/Hits indique le nombre de fois qu’un paquet passe par un routeur sur lequel la translation NAT existe deja.

Si la table de translation NAT est effacee via la commande ‘clear ip nat translation *‘, alors le nombre de Misses augmentera considerablement au passage des paquets dans le routeur vu qu’il y aura creation d’une nouvelle table de translation NAT.

Configuration NAT statique
===========================================

Router2(config)#int f0/0
    (config-if)#ip nat inside
Router2(config-if)#int s0/1/0.201
    (config-subif)#ip nat outside
Router2(config-subif)#int s0/1/0.203
    (config-subif)#ip nat outside

Router2(config)#ip nat inside source static 192.168.2.1 82.0.0.1 ##PC2
    (config)#ip nat inside source static 192.168.2.100 82.0.0.2 ##Server

Verification
« « « « « « « « 
Router2#show ip nat translations
Pro  Inside global     Inside local       Outside local      Outside global
—  82.0.0.2          192.168.2.100      —                —
—  82.0.0.1          192.168.2.1        —                —

Configuration du NAT dyn
===============================================
1. Definir les interfaces
2. Creer le pool
3. creer l’ACL
4. Creer la regle de translation NAT

Router3(config)#int f0/0
    (config-if)#ip nat inside
Router3(config-if)#int s0/1/0.301
    (config-subif)#ip nat outside
Router3(config-subif)#int s0/1/0.302
    (config-subif)#ip nat outside

Router3(config)#ip nat pool NATpool 83.0.0.10 83.0.0.20 netmask 255.25.255.224

Router3(config)#ip access-list standard NATdyna
    (config-std-nacl)#permit 192.168.3.0 0.0.0.63

Router3(config-std-nacl)#ip nat inside source list NATdyna pool NATpool

/!\ si on veut faire du PAT sur notre POOL:
ip nat inside source list NATdyna pool NATpool overload

ACL
========================================================
l’objectif est de filtrer l’acces UNIQUEMENT en HTTP sur le serveur et de bloquer le traffic le plus tot possible.

1. Creer les ACLs
2. Appliquer les ACLs

Router1(config)#ip access-list extended HTTPok
Router1(config-ext-nacl)#permit tcp any host 192.168.2.100 eq 80
    (config-ext-nacl)#permit tcp any host 82.0.0.2 eq 80 ##car NAT sur R2
    (config-ext-nacl)#deny ip any host 192.168.2.100 ##bloquer tout autre traffic vers server
    (config-ext-nacl)#deny ip any host 82.0.0.2
    (config-ext-nacl)#permit ip any any ##autoriser tout le reste vers les autres destinations

Router1(config)#int f0/0
Router1(config-if)#ip access-group HTTPok in

Ajouter OSPF sur les reseaux utilises par le NAT
 » » » » » » » » » » » » » » » » » » » » » » » » » »
sur R2 82.0.0.0 et R3 83.0.0.0

    i. OSPF sur R2
     » » » » » » »’

Router2(config)#router ospf 2
Router2(config-router)#redistribut connected subnets

Verification
« « « « « « « « `
Route statique de R1 vers R2 et R3.

Router1(config)#ip route 82.0.0.0 255.255.255.0 s0/1/0.102
Router1(config)#ip route 83.0.0.0 255.255.255.0 80.0.0.5

======================================================================
Remarque:
======================================================================
Metric pour une route statique est egale a 1 par defaut, mais on peut modifier cette valeur.

Router1(config)#ip route 83.0.0.0 255.255.255.0 80.0.0.5 ?
    Distance metric for this route
 
Router1(config)#ip route 83.0.0.0 255.255.255.0 80.0.0.5 110
Router1#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
       i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
       * – candidate default, U – per-user static route, o – ODR
       P – periodic downloaded static route

Gateway of last resort is not set

     80.0.0.0/30 is subnetted, 3 subnets
C       80.0.0.0 is directly connected, Serial0/1/0.102
C       80.0.0.4 is directly connected, Serial0/1/0.103
O       80.0.0.8 [110/1562] via 80.0.0.2, 01:09:31, Serial0/1/0.102
                 [110/1562] via 80.0.0.5, 01:09:31, Serial0/1/0.103
     82.0.0.0/24 is subnetted, 1 subnets
S       82.0.0.0 is directly connected, Serial0/1/0.102
     83.0.0.0/24 is subnetted, 1 subnets
S       83.0.0.0 [110/0] via 80.0.0.5
C    192.168.1.0/24 is directly connected, FastEthernet0/0
     192.168.2.0/25 is subnetted, 1 subnets
O       192.168.2.0 [110/782] via 80.0.0.2, 01:09:31, Serial0/1/0.102
     192.168.3.0/26 is subnetted, 1 subnets
O       192.168.3.0 [110/782] via 80.0.0.5, 01:09:51, Serial0/1/0.103

======================================================================

Verification
 » » » » » » »
A partir de PC0, ouvrir le lien vers 82.0.0.2:
    1.- https –> Request Timeout en https
    2.- http –> la page s’affiche

Notre ACL fonctionne correctement.

    ii. OSPF sur R3
     » » » » » » » » » »

Router3(config)#ip access-list extended HTTPok
    (config-ext-nacl)#permit tcp any host 82.0.0.2 eq 80
    (config-ext-nacl)#deny ip any host 82.0.0.2
    (config-ext-nacl)#permit ip any any

Router3(config)#int f0/0
    (config-if)#ip access-group HTTPok in

Remarque:
 » » » » » »
On pense a faire nos routes statiques pour que le reseau 82.0.0.0 soit connu par R3 et 83.0.0.0 connu par R2 pour repondre a PC1 et PC4.
Pour R2, on va mettre une ‘default-route’ qui renvoi vers R3.

Router3(config)#ip route 82.0.0.0 255.255.255.0 s0/1/0.302

Router2(config)#ip route 0.0.0.0 0.0.0.0 s0/1/0.203
Router2#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
       i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
       * – candidate default, U – per-user static route, o – ODR
       P – periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     80.0.0.0/30 is subnetted, 3 subnets
C       80.0.0.0 is directly connected, Serial0/1/0.201
O       80.0.0.4 [110/1562] via 80.0.0.1, 01:21:26, Serial0/1/0.201
                 [110/1562] via 80.0.0.10, 01:21:26, Serial0/1/0.203
C       80.0.0.8 is directly connected, Serial0/1/0.203
O    192.168.1.0/24 [110/782] via 80.0.0.1, 01:21:26, Serial0/1/0.201
     192.168.2.0/25 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, FastEthernet0/0
     192.168.3.0/26 is subnetted, 1 subnets
O       192.168.3.0 [110/782] via 80.0.0.10, 01:31:47, Serial0/1/0.203
S*   0.0.0.0/0 is directly connected, Serial0/1/0.203

Verification
 » » » » » » »
A partir de PC1,
    1.- Ouvrir le lien http vers 82.0.0.2
    2.- Ping 82.0.0.2 –> Reply from 192.168.3.62: Destination host unreachable.
    3.- Verification de l’utilisation des ACLs sur R3 suite aux tests 1. et 2.

Router3#show access-lists
Standard IP access list NATdyna
    permit 192.168.3.0 0.0.0.63 (22 match(es))
Extended IP access list HTTPok
    permit tcp any host 82.0.0.2 eq www (5 match(es))
    deny ip any host 82.0.0.2 (16 match(es))
    permit ip any any (4 match(es))

Notre ACL fonctionne correctement.

 Fichier contenant la correction a telecharger: nat_correction.pkt

Publicités

VMware Tools: The path "" is not a valid path – MAJ pour Ubuntu 13.04

Ceci est une mise a jour de mon fil datant du 29 dec 2012, qui ne marche plus avec la version 13.04 d’Ubuntu. J’ai fait quelques recherches sur le net, et la solution qui me convient le mieux est:

cd /lib/modules/$(uname -r)/build/include/linux
sudo ln -s ../generated/utsrelease.h
sudo ln -s ../generated/autoconf.h
sudo ln -s ../generated/uapi/linux/version.h 

Note
Il est a note que le drag-and-drop a l’air de fonctionner correctement pour l’echange de fichiers a partir d’un bureau windows (7, je n’ai pas verifie pour les autres versions) et linux (ubuntu dans mon cas).

Source
Installing VMWare tools on Ubuntu 13.04