X Error of failed request: BadRequest (invalid request code or no such operation)

Si certains d’entre vous rencontre des difficultés à lancer skype, à cause d’une très vielle version, ou de la toute nouvelle (version 8.13.0.2), et ben la solution s’avère d’installer une version ni obsolète ni trop récente.

Je ne me suis pas occupé de ce problème depuis, puisque je n’utilise presque plus Skype, puisque les emails et sms fonctionnent toujours sans problème.

/usr/share/skypeforlinux$ ./skypeforlinux 
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM mic_call
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM call
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM mic_call
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM call
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM mic_call
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM call
X Error of failed request:  BadRequest (invalid request code or no such
operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  42 ()
  Serial number of failed request:  10
  Current serial number in output stream:  10

Je n’ai pas eu à m’occuper de ce problème jusqu’au moment où ma moitée a changé d’ordinateur et que j’ai du tout réinstaller.

 

Pour rappel,

    1. Faire une liste des applications déjà installées, puis supprimer skype
       dpkg -l | grep skype
       sudo dpkg -r skype
       sudo dpkg --purge skype
    2. Télécharger la version 8.11.0.4
      https://repo.skype.com/deb/pool/main/s/skypeforlinux/skypeforlinux_8.11.0.4_amd64.deb
    3. Installer le paquet deb
       sudo dpkg -i skypeforlinux_8.11.0.4_amd64.deb

Et voilà.

Source:

Latest skype crashes

Publicités